June 11, 2015

// // 1 comment

Xposed for Android 5.1 Lollipop (API v64) Alpha 4 Ultra Edition

It seems that many people have waited for this moment, and here we are with the New Xposed for Android 5.1 Lollipop (API v64) Alpha 4 Ultra Edition. I want to start this post off with a couple of very clear points. Rovo89 (Senior XDA Member) is the creator of the Xposed framework. Romracer (also a Senior XDA Member) have only worked to bring the Xposed framework to Android 5.1 Lollipop (API v64) Alpha 4 Ultra Edition. I have not rewritten the Framework from Scratch. If Xposed doesn't work on your 5.0 device, chances are it won't work on 5.1 either (I'm looking at you Samsung users).

This is a derivative work posted with XDA (Rovo89) Permission!

With that said, I present to you the first unofficial release of Xposed for Android 5.1. It is my hope that ultimately my changes can be reviewed and an official release posted. But first, the bugs must be squashed! I've written a few Xposed modules that work fine but by posting this unofficial release, I hope to expand my audience of module writers and testers.

Xposed For Android 5.1 Lollipop

How to Test Xposed for Android 5.1 Lollipop (API v64) :

  • You must be on Android 5.1. It will NOT work on Android 5.0 (too many changes to ART).
  • You should have a working recovery (recoveries that don't have unzip or busybox are not "working recoveries"). The installer will try to detect this ahead of time.
  • If you left the Xposed app installed from Android 5.0, you should disable all modules before installing this framework. Busted modules may keep you from booting after installation otherwise.
  • I will need Xposed logs (and possibly logcats) to debug any issues. Remember, if your device won't boot after installation, its likely you can reboot to recovery and still grab the Xposed log (assuming Zygote started). It will be in /data/data/de.robv.android.xposed.installer/log as error.log or error.log.old.

Known Issues till Now :

  • Devices with very little free space on /system may have trouble installing. This installer has been tweaked slightly over the 5.0 installer. It will attempt to move your original libraries off /system, install the framework, compress the original libraries and then move the compressed originals back to the root of /system.
  • If Xposed for Android 5.0 didn't work on your device, its unlikely this one will either. This is more or less the exact same source code, just an updated ART runtime. But feel free to try, just make sure you know how to backup and restore.

Download Xposed for Android 5.1 Lollipop (API v64) Alpha 4 Edition :

First, I'm going to point you to the original Xposed for Lollipop XDA thread. Why? Because I want you to read it. This release hardly differs from that one. And maybe, just maybe, it'll save some unnecessary private messages. Now, following are the download links for Android 5.1 Lollipop (API v64 Alpha 4 Ultra Edition
Almost everyone should use the arm download. Use arm64 ONLY for arm64 devices (most popular ones are probably HTC One M9 and Nexus 9). Google your device or look in build.prop if you're not sure.
NOTE: This is still an alpha version and for Lollipop on ARMv7+ devices only. Please install it only if you're willing to take the risk of boot loops. Just because it's working fine and stable for me doesn't mean it will work for everyone the same way. 

Module Developers :

It would be incredibly useful to me for people to test the framework in the smallest "units" possible at first. By "unit" I mean things such as "resource replacement", "method replacement", "before method hooks", "after method hooks", etc. It doesn't do me a lot of good to know that some huge, complicated module causes system_server to crash without understanding at what level that's happening. This is actually what held me back from releasing. I have some test modules to use, but I don't have infinite time to write test modules, test the framework, etc.
UPDATE: Samsung has changed quite a few things in their version of ART. It will take more time to adjust Xposed for it.
I hope this Article would help you to Install the Xposed Framework for Android 5.1 Lollipop (API v64) Alpha 4 Ultra Edition. If you face any problems in Installing or Flashing this Xposed Framework, just comment below and I will look forward to your problem.  

1 comment:

  1. Nice blog.

    Recharge your Videocon prepaid mobile recharge instantly from Videocon telecom website anytime anywhere. It is easy and there are no additional charges to recharge online Recharge.

    ReplyDelete